Business

Skype for Business for Android

App Icon

Published by:

Microsoft Corporation

Version:

6.10.0.4

Released:

11. 30. 2016

Size:

Varies with device

Compatible:

Varies with device
Skype for Business, formerly Lync 2013, for Android extends the power of Lync and Skype to your favorite mobile device: voice & video over wireless, rich presence, instant messaging, conferencing, and calling features from a single, easy-to-use interface.

Key Features:
-Initiate a group IM or video conversation and invite additional participants
-Join, rejoin and initiate a Skype for Business Meeting to communicate and collaborate on amazing ideas
-Share your video and view speaker's video during a conference
-Control the meeting (mute or remove attendees) and know more about participants’ modalities
-Look at your upcoming meetings and join via one click
-Find your recent conversations and pick them up from where you left
-Search your contacts by name, email, or phone number
-Enhanced security via Active Directory Authentication Library (ADAL)

Anyone can use the Skype for Business Mobile app when invited to a Skype for Business or Lync 2013 meeting. However, you must have a Skype for Business or Lync account in order to use (and enjoy) the full capability of the Skype for Business Mobile app. Also, some functionality might require an update to Lync or Skype for Business Server or might not be available to all users. If you’re not sure about your account status, please contact your IT department

IMPORTANT: THIS SOFTWARE REQUIRES CONNECTIVITY TO VALIDLY LICENSED COPIES OF MICROSOFT LYNC OR SKYPE FOR BUSINESS SERVER OR OFFICE 365 / LYNC ONLINE / SKYPE FOR BUSINESS ONLINE AND WILL NOT WORK WITHOUT IT. UPDATES TO MICROSOFT LYNC SERVER OR SKYPE FOR BUSINESS MAY BE REQUIRED FOR PROPER PERFORMANCE. SOME FUNCTIONALITY MAY NOT BE AVAILABLE IN ALL COUNTRIES. IF YOU ARE UNSURE ABOUT YOUR COMPANY’S LICENSE TO AND/OR DEPLOYMENT OF LYNC OR SKYPE FOR BUSINESS, PLEASE CONTACT YOUR IT DEPARTMENT. SKYPE FOR BUSINESS APP IS ONLY AVAILABLE FOR Android 4.0 OR GREATER.